Home | About Us | Contact Us


Koi Forum - Koi-Bito Magazine straight from Japan
Results 1 to 7 of 7

Thread: Powerc 1000 uv

  1. #1
    Nisai
    Join Date
    Oct 2011
    Location
    saskatchewan,canada
    Posts
    117

    Powerc 1000 uv

    I just got this last year but never used it. Decided to use it this year so I went and got a bulb and changed it. Got the water flowing through it then plugged it in. The problem is that I can't see the bulb glowing. Are u suppose to be able to see it or is it invisable?

  2. #2
    MCA
    MCA is offline
    Honmei MCA's Avatar
    Join Date
    Dec 2003
    Location
    Atlanta
    Posts
    2,574
    Quote Originally Posted by 300wby View Post
    I just got this last year but never used it. Decided to use it this year so I went and got a bulb and changed it. Got the water flowing through it then plugged it in. The problem is that I can't see the bulb glowing. Are u suppose to be able to see it or is it invisable?

    With most UV units you can see the blue glow through the pipe unions, plastic body..etc.

  3. #3
    Nisai
    Join Date
    Oct 2011
    Location
    saskatchewan,canada
    Posts
    117
    I can't see anything. All I can see is a little glow from that little thing u turn in , not sure what it is called. Ill check and see if I can see it at night

  4. #4
    Honmei ricshaw's Avatar
    Join Date
    Mar 2010
    Location
    Southern California
    Posts
    2,653
    Quote Originally Posted by 300wby View Post
    I just got this last year but never used it. Decided to use it this year so I went and got a bulb and changed it. Got the water flowing through it then plugged it in. The problem is that I can't see the bulb glowing. Are u suppose to be able to see it or is it invisable?
    Are you talking about the Powerclear 1000 UV?


  5. #5
    Nisai
    Join Date
    Oct 2011
    Location
    saskatchewan,canada
    Posts
    117
    That's the one.

  6. #6
    Nisai
    Join Date
    Oct 2011
    Location
    saskatchewan,canada
    Posts
    117
    I changed the starter on it and now it flashes. No idea what to do now and can't seem to find anything on the net. Any ideas?

  7. #7
    Nisai
    Join Date
    Oct 2011
    Location
    saskatchewan,canada
    Posts
    117
    Got the neighbour to come over that is good with electronics and he changed something and now it's working. Thanks

Similar Threads

  1. 1000 subscribed to the board...
    By aquitori in forum Main Forum
    Replies: 9
    Last Post: 09-16-2005, 10:32 AM
  2. Congrats to Keokoi for hitting 1000 posts!!!
    By aquitori in forum Main Forum
    Replies: 9
    Last Post: 09-11-2005, 10:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Articles - Sitemap - FAQs and Rules

KB Footer Graphic
Straight from Japan... For the serious hobbyist!
All content and images copyright of: Koi-bito.com